Back to overview
Downtime
systems going down soon
Apr 29, 2025 at 12:57pm UTC
Affected services
millpixelserver.org
Resolved
Apr 30, 2025 at 5:01pm UTC
alr we prob good rn
Affected services
Created
Apr 29, 2025 at 12:57pm UTC
systems shutting down. check the maintnence page
Affected services